Error after "loading database" - regional settings problem
-> Bug Reports / Feature Requests

#1: Error after "loading database" - regional settings problem Author: quicklead PostPosted: Sun Sep 11, 2011 11:46 am
    ----
Hi.

When I start PointBlank I get program error after "Loading database" message. When I change the regional settings in my system to use "." as a separator instead of "," that is used by default in my country the program runs fine.

Thanks for the nice and useful software!

#2: Re: Error after "loading database" - regional settings problem Author: DallanCLocation: Utah PostPosted: Sun Sep 11, 2011 3:26 pm
    ----
Its a known issue introduced with the last version. I have a fix and need to just complete some further testing to make sure it doesnt cause any additional issues.

That and a new feature (multi-target comparisons) will be in the next version, which should be out later today.


-DallanC

#3: Re: Error after "loading database" - regional settings problem Author: DallanCLocation: Utah PostPosted: Sun Sep 11, 2011 9:19 pm
    ----
A fix is now pushed up.

To use the new Target Comparison feature, select any target and a Compare button will now be visible at the bottom of the tree view. Click that and you will be given a list of *ALL* targets in the database, check the checkboxes of the loads you wish to compare an then change the tab at the bottom of the screen. Its pretty easy and straight forward to use.

-DallanC

#4: Re: Error after "loading database" - regional settings problem Author: SyberShooterLocation: Arizona PostPosted: Wed Sep 14, 2011 11:54 am
    ----
Nice feature implementation however I get an unhandled exception - Index outside bounds of the array. the comparison results show a big red X. Maybe I'm doing something wrong? I did update all my .Net like suggested.

Thanks
al

************** Exception Text **************
System.IndexOutOfRangeException: Index was outside the bounds of the array.
at PointBlank.TargComparison.DrawTarget(Graphics g, TargetTreeNode nodexx, Int32 Left, Int32 Top, Int32 Width, Int32 Height)
at PointBlank.TargComparison.tabPage2_Paint(Object sender, PaintEventArgs e)
at System.Windows.Forms.Control.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3623 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
PointBlank
Assembly Version: 1.0.4271.38082
Win32 Version: 1.0.4271.38082
CodeBase: file:///E:/Shooting/Gun%20Apps/PointBlank-2/PointBlank.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3623 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3624 (GDR.050727-3600)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3082 (QFE.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.3053 (netfxsp.050727-3000)
CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
Microsoft.mshtml
Assembly Version: 7.0.3300.0
Win32 Version: 7.0.3300.0
CodeBase: file:///C:/WINDOWS/assembly/GAC/Microsoft.mshtml/7.0.3300.0__b03f5f7f11d50a3a/Microsoft.mshtml.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

#5: Re: Error after "loading database" - regional settings problem Author: SyberShooterLocation: Arizona PostPosted: Wed Sep 14, 2011 11:58 am
    ----
Sometimes I CAN get it to work and it does compare 2 or 3 targets then other times it won't and just throws error after error.

Can't seem to find the key sequence difference yet.


Last edited by SyberShooter on Wed Sep 14, 2011 4:26 pm; edited 1 time in total

#6: Re: Error after "loading database" - regional settings problem Author: DallanCLocation: Utah PostPosted: Wed Sep 14, 2011 1:01 pm
    ----
SyberShooter wrote:
Sometimes I CAN get it to work and it does compare 2 or 3 or more targets then other times it won't and just throws error after error.

Can't seem to find the key sequence difference yet.

I will run some more tests on it tonight. I did test it pretty heavily with no issues, but it seems something is obviously is wrong. Lemme dig into it further tonight, if you can find repro steps it will make it that much easier.

Sorry for the inconvienence, glad you like it (when it does work lol).


-DallanC

#7: Re: Error after "loading database" - regional settings probl Author: SyberShooterLocation: Arizona PostPosted: Wed Sep 14, 2011 4:19 pm
    ----
I seem to have found the point it stops working. I currently have 147 targets in my db. when I get to # 55 I get the error
"InvalidArgument=value of "54" is not valid for SelectIndex.
ParameterName: SelectIndex"

I don't have to try a compare either, all I have to do is select any listed item after the 53rd one in the list (counting from 0) sometimes I can go back and compare two lower than 53 but after selecting a couple above 54 it then stops working for the lower numbers.
I started at item #1 in the list and use the down-arrow to move to each item. as soon as I hit the 55th item in the list I got the error

The invalid argument # in the error messages increments according to the line item #-1 (base 0 - I understand)
I will upload my data file if you need it for testing.

Looks like it might be an array overflow.
I should'a made this its own thread - sorry

al

#8: Re: Error after "loading database" - regional settings problem Author: DallanCLocation: Utah PostPosted: Wed Sep 14, 2011 7:21 pm
    ----
I reproduced it... working on a fix, its over-flowing the array of "draw colors" when you have alot of entrys selected.


-DallanC

#9: Re: Error after "loading database" - regional settings problem Author: DallanCLocation: Utah PostPosted: Wed Sep 14, 2011 8:32 pm
    ----
Fixed, it will be in the next version release.

I also added a "Select All" button because it was REALLY annoying to try checking all of the targets one at a time.

I also found a bug in that when you duplicate a target, all of the shot info is set to inactive in the new copy. I will fix that as well.


-DallanC

#10: Re: Error after "loading database" - regional settings problem Author: SyberShooterLocation: Arizona PostPosted: Sun Sep 18, 2011 7:03 pm
    ----
[quote="DallanC"


I also found a bug in that when you duplicate a target, all of the shot info is set to inactive in the new copy. I will fix that as well.


-DallanC[/quote]

I thought that was a feature... not a bug! Smile

Is there a way to have all the targets in a collapsed tree and just expand the ones ya wanna work with?

Thanks
Al



-> Bug Reports / Feature Requests

All times are GMT - 7 Hours

Page 1 of 1